Account | Help |
Contact | Services | Whois | DIG |

Site compatibility

This site is designed to work on any standards compliant web browser. Minimum requirements are HTML and HTTP cookies, javascript is desired functionality. Without javascript some functionality may require filling in extra forms.

We recommend using the latest version of one of the following browsers:

All the browsers above have a very good standards compliance record and more importantly all have a very good security record. This does not mean these browsers are bug free but dangerous bugs are fixed very quickly. Users are advised to follow the recommended update procedures for their chosen browser.

Please note that as of January 2010 we do not recommend any version of Internet Explorer. This browser has a very poor standards compliance record but more importantly this browser has a very bad security record. So much so that in January 2010 three governments (Germany, France and Australia) took the extraordinary step and recommended to their citizens that they should not use any versions of this browser.


© SpaceReg 1998-2020